ios – An error occurred whereas processing the post-install hook of the Podfile. no implicit conversion of Hash into String

[ad_1]

React native-ios: i’ve added a brand new package deal react-native-safe-area-context Getting following error when i do pod set up on ios folder,

Putting in react-native-safe-area-context (4.4.1)
Producing Pods undertaking
/Customers/shaikf2/Tasks/RNPOC/ios/Pods/Goal Assist Recordsdata/Pods-RNPOC/Pods-RNPOC.launch.xcconfig
/Customers/shaikf2/Tasks/RNPOC/ios/Pods/Goal Assist Recordsdata/Pods-RNPOC/Pods-RNPOC.debug.xcconfig
/Customers/shaikf2/Tasks/RNPOC/ios/Pods/Goal Assist Recordsdata/Pods-RNPOC-RNPOCTests/Pods-RNPOC-RNPOCTests.launch.xcconfig
/Customers/shaikf2/Tasks/RNPOC/ios/Pods/Goal Assist Recordsdata/Pods-RNPOC-RNPOCTests/Pods-RNPOC-RNPOCTests.debug.xcconfig
Setting REACT_NATIVE construct settings
[!] An error occurred whereas processing the post-install hook of the Podfile.

no implicit conversion of Hash into String

my pod file appears to be like like this

require_relative '../node_modules/react-native/scripts/react_native_pods'
require_relative '../node_modules/@react-native-community/cli-platform-ios/native_modules'

platform :ios, '12.4'
set up! 'cocoapods', :deterministic_uuids => false

goal 'RNPOC' do
  config = use_native_modules!

  # Flags change relying on the env values.
  flags = get_default_flags()
  pod 'Firebase', :modular_headers => true
  pod 'FirebaseCoreInternal', :modular_headers => true
  pod 'GoogleUtilities', :modular_headers => true
  pod 'Firebase/Messaging', :modular_headers => true 
  pod 'FirebaseCore', :modular_headers => true

  use_react_native!(
    :path => config[:reactNativePath],
    # Hermes is now enabled by default. Disable by setting this flag to false.
    # Upcoming variations of React Native might depend on get_default_flags(), however
    # we make it specific right here to assist within the React Native improve course of.
    :hermes_enabled => true,
    :fabric_enabled => flags[:fabric_enabled],
    # Permits Flipper.
    #
    # Notice that in case you have use_frameworks! enabled, Flipper won't work and
    # you need to disable the following line.
    # :flipper_configuration => FlipperConfiguration.disabled,
    # An absolute path to your software root.
    :app_path => "#{Pod::Config.occasion.installation_root}/.."
  )

  goal 'RNPOCTests' do
    inherit! :full
    # Pods for testing
  finish

  post_install do |installer|
    react_native_post_install(
      installer,
      # Set `mac_catalyst_enabled` to `true` in an effort to apply patches
      # needed for Mac Catalyst builds
      :mac_catalyst_enabled => false
    )
    __apply_Xcode_12_5_M1_post_install_workaround(installer)
  finish
finish

and package deal.json appears to be like like this

{
  "title": "RNPOC",
  "model": "0.0.1",
  "personal": true,
  "scripts": {
    "android": "react-native run-android",
    "ios": "react-native run-ios",
    "begin": "react-native begin",
    "fonts": "react-native-asset",
    "check": "jest",
    "lint": "eslint .",
    "clear": "cd android && gradlew clear && cd ..",
    "build-android": "cd android && gradlew clear && gradlew app:assembleRelease && cd .."
  },
  "dependencies": {
    "@react-native-async-storage/async-storage": "^1.17.7",
    "@react-native-clipboard/clipboard": "^1.10.0",
    "@react-native-firebase/app": "^15.1.1",
    "@react-native-firebase/messaging": "^15.1.1",
    "@react-navigation/material-top-tabs": "^6.2.2",
    "@react-navigation/native": "^6.0.11",
    "@react-navigation/native-stack": "^6.7.0",
    "axios": "^0.27.2",
    "pod-install": "^0.1.38",
    "react": "18.0.0",
    "react-native": "0.69.1",
    "react-native-asset": "^2.0.1",
    "react-native-linear-gradient": "^2.6.2",
    "react-native-msal": "^4.0.4",
    "react-native-network-info": "^5.2.1",
    "react-native-pager-view": "^5.4.25",
    "react-native-push-notification": "^8.1.1",
    "react-native-responsive-screen": "^1.4.2",
    "react-native-safe-area-context": "^4.3.1",
    "react-native-screens": "^3.15.0",
    "react-native-tab-view": "^3.1.1",
    "react-native-vector-icons": "^9.2.0"
  },
  "devDependencies": {
    "@babel/core": "^7.12.9",
    "@babel/runtime": "^7.12.5",
    "@react-native-community/eslint-config": "^2.0.0",
    "babel-jest": "^26.6.3",
    "eslint": "^7.32.0",
    "jest": "^26.6.3",
    "metro-react-native-babel-preset": "^0.70.3",
    "react-test-renderer": "18.0.0"
  },
  "jest": {
    "preset": "react-native"
  }
}

Issues i attempted already:
Cleared node_modules and Pod file and reinstalled, however nonetheless not in a position to resolve it, i’m new to ios builds, it might be useful if i can resolve this.

[ad_2]

Leave a Reply